Welcome

This help file contains the LabVIEW programming information for the Keysight M9217A PXIe 2-CH Digitizer.

Related Topics

  • Introduction

  • Programming Examples

  • Method (VI) Reference

Related Documentation

To access the documentation related to the M9217A PXIe 2-CH Digitizer, use one of the following methods:

  • Browse the product CD

  • Browse the manuals

  • Visit the product Web site (www.keysight.com/find/m9217a)

  • Go to Start > All Programs > Keysight > M9217: Provides links to all product documentation except for the IVI driver help system.

  • Go to Start > All Programs > Keysight Instrument Drivers > IVI-COM-C Drivers > KtM9217 Dynamic DAC: Provides the link to the product IVI driver help system.

Additional Information

  • For the latest product information and updated application, refer to http://www.keysight.com/find/m9217a.

  • Product information and descriptions in this help file are subject to change without notice.

Contact Keysight Technologies

© Keysight Technologies 2015
Edition 1, October 1, 2015


Introduction to the Microwave Switch Module LabVIEW Driver

Introduction to the M9217A PXIe 2-CH Digitizer LabVIEW Driver

This instrument driver provides access to the functionality of the Keysight M9217A PXIe 2-CH Digitizer from the National Instruments LabVIEW software.

For more information on this driver and other instrument drivers and software available from Keysight Technologies, visit: http://www.keysight.com/find/drivers

LabVIEW is a registered trademark of National Instruments.

See Also

  • Keysight M9217A PXIe 2-CH Digitizer product website

  • Programming examples

  • Methods (VIs)


M9217A Functional Block Diagram


Programming Examples for the Microwave Switch Module LabVIEW Driver

Programming Examples for the M9217A PXIe 2-CH Digitizer LabVIEW Driver

  • Immediate.vi

  • ChannelTrigger.vi

  • OutputDestination.vi

  • MultiRecord.vi


Keysight M9217.lvlib:Keysight M9217-Immediate.vi

Keysight M9217-Immediate.vi

This example initializes the instrument, reads a few instrument identity parameters and configures instrument to acquire waveforms in Immediate mode.


Keysight M9217.lvlib:Keysight M9217-ChannelTrigger.vi

Keysight M9217-ChannelTrigger.vi

This example initializes the instrument, reads a few instrument identity parameters and configures instrument to acquire waveforms in Channel Trigger mode.


Keysight M9217.lvlib:Keysight M9217-OutputDestination.vi

Keysight M9217-OutputDestination.vi

This example initializes the instrument, reads a few instrument identity parameters and configures instrument to output a trigger pulse to OutputDestination when the trigger event signal is accepted. When trigger event is accepted, a trigger pulse is outputted to OutputDestination.


Keysight M9217.lvlib:Keysight M9217-Multirecord.vi

Keysight M9217-Multirecord.vi

This example initializes the instrument, reads a few instrument identity parameters and configures instrument to acquire multiple waveform records in Software Trigger mode.


Methods

This section provides detailed descriptions of the Keysight M9217A PXIe 2-CH Digitizer LabVIEW driver VIs.

See Also

Programming examples


Keysight M9217.lvlib:VI Tree.vi

The VI Tree displays all the user-callable VIs of the instrument driver in an organized table.


Keysight M9217.lvlib:Initialize.vi

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

resource string

A string that specifies the instrument to connect to. This can either be a VISA resource name (also known as a VISA address) or an IVI session, or an IVI logical name. For PXI instruments, a VISA resource name is of the form:

PXI[bus]::[device]::INSTR

PXI0::[bus]-[device]::INSTR

PXI0::CHASSIS[chassis]::SLOT[slot]::INSTR

For example, the following are syntactically correct strings:

PXI1::3::INSTR

PXI0:1-3::INSTR

PXI0::CHASSIS1::SLOT3::INSTR

VISA resource names for devices connected to your computer can be found using the Keysight Connection Expert.

To configure an IVI session or IVI Logical name, consult the IVI tools on your system, such as NI-MAX (Keysight devices may not appear in NI Max).
id query (Off)

Specifies whether to verify the ID of the instrument.
reset device (Off)

Specifies whether to reset the instrument.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
instrument handle out
Unique identifier for an IVI session.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Keysight M9217.lvlib:Initialize With Options.vi

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

resource string

A string that specifies the instrument to connect to. This can either be a VISA resource name (also known as a VISA address) or an IVI session, or an IVI logical name. For PXI instruments, a VISA resource name is of the form:

PXI[bus]::[device]::INSTR

PXI0::[bus]-[device]::INSTR

PXI0::CHASSIS[chassis]::SLOT[slot]::INSTR

For example, the following are syntactically correct strings:

PXI1::3::INSTR

PXI0:1-3::INSTR

PXI0::CHASSIS1::SLOT3::INSTR

VISA resource names for devices connected to your computer can be found using the Keysight Connection Expert.

To configure an IVI session or IVI Logical name, consult the IVI tools on your system, such as NI-MAX (Keysight devices may not appear in NI Max).
id query (Off)

Specifies whether to verify the ID of the instrument.
reset device (Off)
Specifies whether to reset the instrument.
option string
The user can use the OptionsString parameter to specify the initial values of certain IVI inherent properties for the session. The format of an assignment in the OptionsString parameter is "Name=Value", where Name is one of: RangeCheck, QuerytInstrStatus, Cache, Simulate, RecordCoercions, InterchangeCheck,or DriverSetup. Value is either true or false except for DriverSetup. If the Options String parameter contains an assignment for the Driver Setup property, the Initialize function assumes that everything following "DriverSetup=" is part of the assignment.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
instrument handle out
Unique identifier for an IVI session.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Keysight M9217.lvlib:Close.vi

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Keysight M9217.lvlib:Abort.vi

Aborts an acquisition and returns the digitizer to the Idle state.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
instrument handle out
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Keysight M9217.lvlib:Initiate Acquisition.vi

Initiates a waveform acquisition. The digitizer leaves the Idle state and waits for a trigger. The digitizer acquires a waveform for each enabled channel.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
instrument handle out
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Keysight M9217.lvlib:Wait For Acquisition Complete.vi

Waits until the configured acquisition is complete. If no acquisition is currently running, this VI returns immediately. If the acquisition does not complete within the time period the user specified with the MaxTimeMilliseconds parameter, the VI returns the Max Time Exceeded error.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Maximum Time (0 ms)
Specifies the maximum time the end-user allows for this function to complete. The units are milliseconds. Defined values:Max Time Infinite (same or less than zero) - The function waits indefinitely for the acquisition to complete.
instrument handle out
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Keysight M9217.lvlib:Is Idle.vi

This VI is used to determine if the digitizer is currently in the Idle state.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
instrument handle out
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Status

Returns whether the digitizer is currently in the Idle state. If the driver cannot query the instrument to determine its state, the driver returns the value Unknown.

Return values are :-

1 : The digitizer is currently in the queried state.

2 : The digitizer is not currently in the queried state.

3 : The driver cannot query the instrument to determine if the digitizer is in the queried state.


Keysight M9217.lvlib:Is Measuring.vi

This VI is used to determine if the digitizer is currently in the Measuring state.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
instrument handle out
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Status

Returns whether the digitizer is currently in the Measuring state. If the driver cannot query the instrument to determine its state, the driver returns the value Unknown.

Return values are :-

1 : The digitizer is currently in the queried state.

2 : The digitizer is not currently in the queried state.

3 : The driver cannot query the instrument to determine if the digitizer is in the queried state.


Keysight M9217.lvlib:Is Waiting For Trigger.vi

This VI is used to determine if the digitizer is currently in the Waiting For Trigger state.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
instrument handle out
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Status
Returns whether the digitizer is currently in the WaitingForTrigger state. If the driver cannot query the instrument to determine its state, the driver returns the value Unknown.

Return values are :-

1 : The digitizer is currently in the queried state.

2 : The digitizer is not currently in the queried state.

3 : The driver cannot query the instrument to determine if the digitizer is in the queried state.


Keysight M9217.lvlib:Fetch Waveform Measurement.vi

Returns a previously acquired waveform measurement for this channel. The acquisition must be made prior to calling this method. Call this method separately for each measurement.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Channel (Channel1)

The physical or virtual repeated capability identifier. Pass VI_NULL (0) or empty string if operation does not apply to a repeated capability.
MeasFunction (Rise Time)
Characteristic of the acquired waveform to be measured.

Rise Time : The length of time for a rising edge of the signal to rise from the low reference level to the high reference level. The units are seconds.

Fall Time : The length of time for a falling edge of the signal to fall from the high reference level to the low reference level. The units are seconds.

Frequency : The frequency of one complete cycle in the waveform. The units are Hertz.

Period : The length of time of one complete cycle in the waveform. The units are seconds.

Voltagerms : The true Root Mean Square voltage of the entire waveform. The units are Volts.

Votage Peak To Peak : The absolute difference between the Voltage Max and the Voltage Min. The units are Volts.

Voltage Max : The maximum amplitude found in the entire waveform. The units are Volts.

Voltage Min : The minimum amplitude found in the entire waveform. The units are Volts.

Voltage High : The voltage that corresponds to 100% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods. The min/max method uses the maximum value found. The histogram method uses a common value found above the middle of the waveform. The units are Volts.

Voltage Low : The voltage that corresponds to 0% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods. The min/max method uses the minimum value found. The histogram method uses a common value found below the middle of the waveform. The units are Volts.

Voltage Average : The arithmetic average in volts measured over the entire waveform. The units are Volts.

Width Neg : The length of time between the mid reference level points of a negative pulse in the waveform. The units are seconds.

Width Pos : The length of time between the mid reference level points of a positive pulse in the waveform. The units are seconds.

Duty Cycle Neg : The ratio of the Width Neg to the Period of an integer number of cycles in the waveform expressed as a percentage.

Duty Cycle Pos : The ratio of the Width Pos width to the Period of an integer number of cycles in the waveform expressed as a percentage.

Amplitude : The Voltage High less the Voltage Low in Volts over the entire waveform.

Voltage Cyclerms : The true Root Mean Square voltage over an integer number of cycles in the waveform. The units are Volts.

Voltage Cycle Average : The arithmetic average in Volts over an integer number of cycles in the waveform. The units are Volts.

Over Shoot : The relative waveform distortion that follows an edge transition.

Preshoot : The relative waveform distortion that precedes an edge transition.
instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Measurement

The measured value. The units depend on the measurement that the user specifies with the measFunction parameter.


Keysight M9217.lvlib:Read Waveform Measurement.vi

Initiates an acquisition on all enabled channels, waits (up to MaxTime) for the acquisition to complete, and returns the measurement for this channel. Call FetchWaveformMeasurement to obtain other measurements for this or other channels.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Channel (Channel1)

The physical or virtual repeated capability identifier. Pass VI_NULL (0) or empty string if operation does not apply to a repeated capability.
MeasFunction (Rise Time)
Characteristic of the acquired waveform to be measured.

Rise Time : The length of time for a rising edge of the signal to rise from the low reference level to the high reference level. The units are seconds.

Fall Time : The length of time for a falling edge of the signal to fall from the high reference level to the low reference level. The units are seconds.

Frequency : The frequency of one complete cycle in the waveform. The units are Hertz.

Period : The length of time of one complete cycle in the waveform. The units are seconds.

Voltagerms : The true Root Mean Square voltage of the entire waveform. The units are Volts.

Votage Peak To Peak : The absolute difference between the Voltage Max and the Voltage Min. The units are Volts.

Voltage Max : The maximum amplitude found in the entire waveform. The units are Volts.

Voltage Min : The minimum amplitude found in the entire waveform. The units are Volts.

Voltage High : The voltage that corresponds to 100% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods. The min/max method uses the maximum value found. The histogram method uses a common value found above the middle of the waveform. The units are Volts.

Voltage Low : The voltage that corresponds to 0% when using the reference levels. The oscilloscope calculates this value using either the min/max or histogram methods. The min/max method uses the minimum value found. The histogram method uses a common value found below the middle of the waveform. The units are Volts.

Voltage Average : The arithmetic average in volts measured over the entire waveform. The units are Volts.

Width Neg : The length of time between the mid reference level points of a negative pulse in the waveform. The units are seconds.

Width Pos : The length of time between the mid reference level points of a positive pulse in the waveform. The units are seconds.

Duty Cycle Neg : The ratio of the Width Neg to the Period of an integer number of cycles in the waveform expressed as a percentage.

Duty Cycle Pos : The ratio of the Width Pos width to the Period of an integer number of cycles in the waveform expressed as a percentage.

Amplitude : The Voltage High less the Voltage Low in Volts over the entire waveform.

Voltage Cyclerms : The true Root Mean Square voltage over an integer number of cycles in the waveform. The units are Volts.

Voltage Cycle Average : The arithmetic average in Volts over an integer number of cycles in the waveform. The units are Volts.

Over Shoot : The relative waveform distortion that follows an edge transition.

Preshoot : The relative waveform distortion that precedes an edge transition.
MaxTimeMilliseconds (0 ms)

Specifies the maximum time the end-user allows for this method to complete in milliseconds.
instrument handle out
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Measurement

The measured value. The units depend on the measurement that the user specifies with the measFunction parameter.


Keysight M9217.lvlib:Get Channel Name.vi

This VI returns the physical channel identifier that corresponds to the one-based index that the user specifies. If the value that the user passes for the Index parameter is less than one or greater than the value of the Channel Count, the VI returns an empty string in the Name parameter and returns an error.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Channel Index (1)
A one-based index that defines which name to return.
instrument handle out
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Channel Name

A user-allocated (for IVI-C) or driver-allocated (for IVI-COM) buffer into which the driver stores the channel name. The caller may pass VI_NULL (0) for this parameter if the NameBufferSize parameter is 0.


Keysight M9217.lvlib:Get Trigger Source Name.vi

This VI returns the physical channel identifier that corresponds to the one-based index that the user specifies. If the value that the user passes for the Index parameter is less than one or greater than the value of the Trigger Source Count, the VI returns an empty string in the Name parameter and returns an error.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Source Index (1)
A one-based index that defines which name to return.
instrument handle out
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Source Name

A user-allocated (for IVI-C) or driver-allocated (for IVI-COM) buffer into which the driver stores the channel name. The caller may pass VI_NULL (0) for this parameter if the NameBufferSize parameter is 0.


Keysight M9217.lvlib:Query Min Waveform Memory.vi

This VI is used to determine the minimum amount of memory that is needed to fetch or read data from the digitizer with maximum performance.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Data Width (16)
Specifies the size of the sampled data that will be retrieved. The value of this parameter must be 16, 32 or 64, corresponding to the intended Read/Fetch function.
Number of Records (1)
Specifies the number of records that will be read.
Offset Within Record (0)
Specifies the start index within the record from which the data should be retrieved.
Number of Points Per Record (100)
Specifies the number of data points to return.
instrument handle out
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Number of Samples

The minimum buffer size in samples needed for a subsequent Read or Fetch call with the same readout parameters.


Keysight M9217.lvlib:Send Software Trigger.vi

Refer to IVI-3.3: Standard Cross-Class Capabilities Specification for the prototype and complete description of this VI.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
instrument handle out
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Keysight M9217.lvlib:GetAttributeViBoolean.vi

Gets a Boolean attribute from the instrument driver. The following Attributes are supported:

CHANNEL_ENABLED

INPUT_FILTER_BYPASS

SIMULATE

SYSTEM_TRACE_ENABLED

TRIGGER_OUTPUT_ENABLED

instrument handle
This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:
(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
RepCapIdentifier
If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL (0) or an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".
AttributeID

Selects which attribute will be accessed. The following Attributes are supported:

CHANNEL_ENABLED : Specifies whether the digitizer acquires a waveform for the channel. The returned value will always be true.

INPUT_FILTER_BYPASS : Specifies whether or not to bypass the input filter.

SIMULATE : If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.

SYSTEM_TRACE_ENABLED : If true, output trace log of all driver calls to an XML file using a unique file name based on date and time in the same directory as the application executable accessing the driver OR as specified using tracing options when initializing the driver. See remarks below for tracing options information. The log file may be viewed in your web browser. If enabled, driver trace and additional IO events may also be viewed in the IO Monitor utility of Keysight IO Libraries 16.0 or newer.

TRIGGER_OUTPUT_ENABLED : Specifies whether or not an accepted trigger appears at an output of the digitizer.
instrument handle out
This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:
(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.


Keysight M9217.lvlib:GetAttributeViInt32.vi

Gets an Int32 attribute from the instrument driver.The following Attributes are supported:

CHANNEL_COUNT

INPUT_FILTER

IS_IDLE

IS_MEASURING

IS_WAITING_FOR_TRIGGER

SLOT_NUMBER

TRIGGER_SLOPE

TRIGGER_SOURCE_COUNT

TRIGGER_TYPE

VERTICAL_COUPLING

WINDOW_TRIGGER_CONDITION

instrument handle
This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:
(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
RepCapIdentifier
If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL (0) or an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".
AttributeID

Selects which attribute will be accessed. The following attributes are supported :

CHANNEL_COUNT : The number of channels.

INPUT_FILTER : Specify the appropriate digital filter for the channel.

IS_IDLE : Returns whether the device is currently in the Idle state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.

IS_MEASURING : Returns whether the device is currently in the Measuring state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.

IS_WAITING_FOR_TRIGGER : Returns whether the device is currently in the Waiting For Trigger state. If the driver cannot query the digitizer to return its state, the driver returns the value Unknown.

SLOT_NUMBER : Returns the slot number of the card.

TRIGGER_SLOPE : Specifies whether a rising or a falling edge triggers the digitizer. This attribute affects instrument operation only when the Trigger Type attribute is set to Edge Trigger.

TRIGGER_SOURCE_COUNT : The number of trigger sources.

TRIGGER_TYPE : The kind of event that triggers the digitizer.

VERTICAL_COUPLING : Specifies how the digitizer couples the input signal for the channel.

WINDOW_TRIGGER_CONDITION : Specifies whether a signal that is entering or leaving the voltage window defined by the high and low thresholds triggers the digitizer. The end-user specifies the high and low thresholds with the Window High Threshold and Window Low Threshold attributes.
instrument handle out
This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:
(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.


Keysight M9217.lvlib:GetAttributeViInt64.vi

Gets an Int64 attribute from the instrument driver.The following Attributes are supported:

MAX_FIRST_VALID_POINT_VAL

MAX_SAMPLES_PER_CHANNEL

MIN_RECORD_SIZE

NUM_ACQUIRED_RECORDS

NUM_RECORDS_TO_ACQUIRE

PRETRIGGER_SAMPLES

RECORD_SIZE

instrument handle
This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:
(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
AttributeID

Selects which attribute will be accessed. The following attributes are supported :

MAX_FIRST_VALID_POINT_VAL : Returns the maximum value that the First Valid Point parameter of the readout functions may assume. This value is necessary to calculate the minimum size of the required data buffer to retrieved the entire acquisition.

MAX_SAMPLES_PER_CHANNEL : Returns the maximum number of samples per channel that can be captured.

MIN_RECORD_SIZE : Indicates the minimum waveform record size.

NUM_ACQUIRED_RECORDS : Gets the total number of records acquired since the acquistion was last initiated. You may call this method while an acquisition is in progress.

NUM_RECORDS_TO_ACQUIRE : Specifies the number of waveform records to acquire. One waveform record is acquired for each recognized trigger.

PRETRIGGER_SAMPLES : Specifies the number of samples that must be collected before a trigger event will be recognized. The Pretrigger Samples attribute affects instrument operation only when the digitizer requires multiple acquisitions to build a complete waveform. If Trigger Holdoff and Pretrigger Samples are are both non-zero, then both conditions must be satisfied before the digitizer will accept a trigger.

RECORD_SIZE : Specifies the number of samples to acquire in each waveform record.
instrument handle out
This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:
(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.


Keysight M9217.lvlib:GetAttributeViReal64.vi

Gets an Real64 attribute from the instrument driver.The following Attributes are supported:

INPUT_IMPEDANCE

REFERENCE_LEVEL_HIGH

REFERENCE_LEVEL_LOW

REFERENCE_LEVEL_MID

SAMPLE_RATE

TRIGGER_DELAY

TRIGGER_HOLDOFF

TRIGGER_HYSTERESIS

TRIGGER_LEVEL

VERTICAL_RANGE

WINDOW_TRIGGER_HIGH_THRESHOLD

WINDOW_TRIGGER_LOW_THRESHOLD

instrument handle
This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:
(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
RepCapIdentifier
If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL (0) or an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".
AttributeID

Selects which attribute will be accessed. The following attributes are supported :

INPUT_IMPEDANCE : The input impedance of this channel. The units are Ohms.

REFERENCE_LEVEL_HIGH : The high reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.

REFERENCE_LEVEL_LOW : The low reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.

REFERENCE_LEVEL_MID : The mid reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.

SAMPLE_RATE : Specifies the rate of the sample clock in samples per second. This number represents the inverse of the interval between samples in the acquisition record.

TRIGGER_DELAY : Specifies the length of time from the trigger event to the first point in the waveform record. If the value is positive, the first point in the waveform record occurs after the trigger event. If the value is negative, the first point in the waveform record occurs before the trigger event. The units are seconds.

TRIGGER_HOLDOFF : Specifies the length of time the digitizer waits after it detects a trigger until the digitizer enables the trigger subsystem to detect another trigger. The units are seconds. The Trigger Holdoff attribute affects instrument operation only when the digitizer requires multiple acquisitions to build a complete waveform. If Trigger Holdoff and PreTriggerSamples are both non-zero, then both conditions must be satisfied before the digitizer will accept a trigger. Note: Many digitizers have a small, non-zero value as the minimum value for this attribute. To configure the instrument to use the shortest trigger hold-off, the user can specify a value of zero for this attribute. Therefore, the IVI Class-Compliant specific driver shall coerce any value between zero and the minimum value to the minimum value. No other coercion is allowed on this attribute.

TRIGGER_HYSTERESIS : Specifies the trigger hysteresis in Volts.

TRIGGER_LEVEL : Specifies the voltage threshold for the trigger sub-system. The units are Volts. This attribute affects instrument behavior only when the Trigger Type is set to one of the following values: Edge Trigger, Glitch Trigger, or Width Trigger. This attribute, along with the Trigger Slope, Trigger Source, and Trigger Coupling attributes, defines the trigger event when the Trigger Type is set to Edge Trigger.

VERTICAL_RANGE : The absolute value of the input range the digitizer can acquire for the channel. The units are Volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 8.0 volts.

WINDOW_TRIGGER_HIGH_THRESHOLD : Specifies the high window threshold voltage in Volts.

WINDOW_TRIGGER_LOW_THRESHOLD : Specifies the low window threshold voltage in Volts.
instrument handle out
This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:
(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.


Keysight M9217.lvlib:GetAttributeViString.vi

Gets a String attribute from the instrument driver. The following Attributes are supported:

ACTIVE_TRIGGER_SOURCE

BOARD_REVISION

CALIBRATION_DATE

DRIVER_REVISION

DRIVER_SETUP

FPGA_REVISION

INSTRUMENT_FIRMWARE_REVISION

INSTRUMENT_MANUFACTURER

INSTRUMENT_MODEL

IO_RESOURCE_DESCRIPTOR

LOGICAL_NAME

SPECIFIC_DRIVER_DESCRIPTION

SPECIFIC_DRIVER_REVISION

SPECIFIC_DRIVER_VENDOR

SUPPORTED_INSTRUMENT_MODELS

SYSTEM_SERIAL_NUMBER

TRIGGER_OUTPUT_DESTINATION

instrument handle
This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:
(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
AttributeID

Selects which attribute will be accessed. The following attributes are supported :

ACTIVE_TRIGGER_SOURCE : Specifies the source the digitizer monitors for the trigger event. The value specified here must be one of the valid repeated capability names for the TriggerSource repeated capability ("Immediate" or "External" or "PXI_STAR" or "PXI_TRIG0" or "PXI_TRIG1" or "PXI_TRIG02" or "PXI_TRIG3" or "PXI_TRIG4" or "PXI_TRIG5" or "PXI_TRIG6" or "PXI_TRIG7" or "Channel1" or "Channel2").

BOARD_REVISION : Returns the PCB version.

CALIBRATION_DATE : Returns the calibration date from EEPROM.

DRIVER_REVISION : Returns the fundamental driver revision.

DRIVER_SETUP : The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.

FPGA_REVISION : Returns the FPGA firmware version.

INSTRUMENT_FIRMWARE_REVISION : The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.

INSTRUMENT_MANUFACTURER : The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes.

INSTRUMENT_MODEL : The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes.

IO_RESOURCE_DESCRIPTOR : The resource descriptor specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.

LOGICAL_NAME : Logical Name identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.

SPECIFIC_DRIVER_DESCRIPTION : Returns a brief description of the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

SPECIFIC_DRIVER_REVISION : Returns version information about the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

SPECIFIC_DRIVER_VENDOR : Returns the name of the vendor that supplies the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

SUPPORTED_INSTRUMENT_MODELS : A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.

SYSTEM_SERIAL_NUMBER : The instrument serial number.

TRIGGER_OUTPUT_DESTINATION : Specifies whether or not an accepted trigger appears at an output destination of the digitizer. This is a string containing trigger output pulse ("OFF" or "External" or "PXI_TRIG0" or "PXI_TRIG1" or "PXI_TRIG2" or "PXI_TRIG3" or "PXI_TRIG4" or "PXI_TRIG5" or "PXI_TRIG6" or "PXI_TRIG7").
instrument handle out
This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:
(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
AttributeValue

The buffer in which the VI returns the current value of the property. Can be VI_NULL (0) if AttributeValueBufferSize is 0.


Keysight M9217.lvlib:SetAttributeViBoolean.vi

Sets a Boolean attribute from the instrument driver. The following Attributes are supported:

INPUT_FILTER_BYPASS

SIMULATE

SYSTEM_TRACE_ENABLED

instrument handle
This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:
(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
RepCapIdentifier
If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL (0) or an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".
AttributeID

Selects which attribute will be accessed. The following Attributes are supported:

INPUT_FILTER_BYPASS : Specifies whether or not to bypass the input filter.

SIMULATE : If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.

SYSTEM_TRACE_ENABLED : If true, output trace log of all driver calls to an XML file using a unique file name based on date and time in the same directory as the application executable accessing the driver OR as specified using tracing options when initializing the driver. See remarks below for tracing options information. The log file may be viewed in your web browser. If enabled, driver trace and additional IO events may also be viewed in the IO Monitor utility of Keysight IO Libraries 16.0 or newer.
AttributeValue (Off)
The value to which to set the property.
instrument handle out
This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:
(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Keysight M9217.lvlib:SetAttributeViInt32.vi

Sets an Int32 attribute from the instrument driver. The following Attributes are supported:

INPUT_FILTER

TRIGGER_SLOPE

TRIGGER_TYPE

VERTICAL_COUPLING

WINDOW_TRIGGER_CONDITION

instrument handle
This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:
(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
RepCapIdentifier
If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL (0) or an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".
AttributeID

Selects which attribute will be accessed. The following attributes are supported :

INPUT_FILTER : Specify the appropriate digital filter for the channel.

TRIGGER_SLOPE : Specifies whether a rising or a falling edge triggers the digitizer. This attribute affects instrument operation only when the Trigger Type attribute is set to Edge Trigger.

TRIGGER_TYPE : The kind of event that triggers the digitizer.

VERTICAL_COUPLING : Specifies how the digitizer couples the input signal for the channel.

WINDOW_TRIGGER_CONDITION : Specifies whether a signal that is entering or leaving the voltage window defined by the high and low thresholds triggers the digitizer. The end-user specifies the high and low thresholds with the Window High Threshold and Window Low Threshold attributes.
AttributeValue

The value to which to set the property.
instrument handle out
This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:
(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Keysight M9217.lvlib:SetAttributeViInt64.vi

Sets an Int64 attribute from the instrument driver. The following Attributes are supported:

NUM_RECORDS_TO_ACQUIRE

PRETRIGGER_SAMPLES

RECORD_SIZE

instrument handle
This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:
(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
AttributeID

Selects which attribute will be accessed. The following attributes are supported :

NUM_RECORDS_TO_ACQUIRE : Specifies the number of waveform records to acquire. One waveform record is acquired for each recognized trigger.

PRETRIGGER_SAMPLES : Specifies the number of samples that must be collected before a trigger event will be recognized. The Pretrigger Samples attribute affects instrument operation only when the digitizer requires multiple acquisitions to build a complete waveform. If Trigger Holdoff and Pretrigger Samples are are both non-zero, then both conditions must be satisfied before the digitizer will accept a trigger.

RECORD_SIZE : Specifies the number of samples to acquire in each waveform record.
AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.
instrument handle out
This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:
(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Keysight M9217.lvlib:SetAttributeViReal64.vi

Sets an Real64 attribute from the instrument driver. The following Attributes are supported:

REFERENCE_LEVEL_HIGH

REFERENCE_LEVEL_LOW

REFERENCE_LEVEL_MID

SAMPLE_RATE

TRIGGER_DELAY

TRIGGER_HOLDOFF

TRIGGER_HYSTERESIS

TRIGGER_LEVEL

VERTICAL_RANGE

WINDOW_TRIGGER_HIGH_THRESHOLD

WINDOW_TRIGGER_LOW_THRESHOLD

instrument handle
This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:
(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL (0) or an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".
AttributeID

Selects which attribute will be accessed. The following attributes are supported :

REFERENCE_LEVEL_HIGH : The high reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.

REFERENCE_LEVEL_LOW : The low reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.

REFERENCE_LEVEL_MID : The mid reference for waveform measurements. It is a percentage of the difference between the Voltage High and Voltage Low. Voltage High and Voltage Low may be calculated using either the min/max or histogram methods.

SAMPLE_RATE : Specifies the rate of the sample clock in samples per second. This number represents the inverse of the interval between samples in the acquisition record.

TRIGGER_DELAY : Specifies the length of time from the trigger event to the first point in the waveform record. If the value is positive, the first point in the waveform record occurs after the trigger event. If the value is negative, the first point in the waveform record occurs before the trigger event. The units are seconds.

TRIGGER_HOLDOFF : Specifies the length of time the digitizer waits after it detects a trigger until the digitizer enables the trigger subsystem to detect another trigger. The units are seconds. The Trigger Holdoff attribute affects instrument operation only when the digitizer requires multiple acquisitions to build a complete waveform. If Trigger Holdoff and PreTriggerSamples are both non-zero, then both conditions must be satisfied before the digitizer will accept a trigger. Note: Many digitizers have a small, non-zero value as the minimum value for this attribute. To configure the instrument to use the shortest trigger hold-off, the user can specify a value of zero for this attribute. Therefore, the IVI Class-Compliant specific driver shall coerce any value between zero and the minimum value to the minimum value. No other coercion is allowed on this attribute.

TRIGGER_HYSTERESIS : Specifies the trigger hysteresis in Volts.

TRIGGER_LEVEL : Specifies the voltage threshold for the trigger sub-system. The units are Volts. This attribute affects instrument behavior only when the Trigger Type is set to one of the following values: Edge Trigger, Glitch Trigger, or Width Trigger. This attribute, along with the Trigger Slope, Trigger Source, and Trigger Coupling attributes, defines the trigger event when the Trigger Type is set to Edge Trigger.

VERTICAL_RANGE : The absolute value of the input range the digitizer can acquire for the channel. The units are Volts. For example, to acquire a sine wave spanning -5.0 to 5.0 volts, set Range to 8.0 volts.

WINDOW_TRIGGER_HIGH_THRESHOLD : Specifies the high window threshold voltage in Volts.

WINDOW_TRIGGER_LOW_THRESHOLD : Specifies the low window threshold voltage in Volts.
AttributeValue

The value to which to set the property.
instrument handle out
This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:
(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Keysight M9217.lvlib:SetAttributeViString.vi

Sets a String attribute from the instrument driver. The following Attributes are supported:

ACTIVE_TRIGGER_SOURCE

TRIGGER_OUTPUT_DESTINATION

instrument handle
This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:
(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
AttributeID

Selects which attribute will be accessed. The following attributes are supported :

ACTIVE_TRIGGER_SOURCE : Specifies the source the digitizer monitors for the trigger event. The value specified here must be one of the valid repeated capability names for the TriggerSource repeated capability ("Immediate" or "External" or "PXI_STAR" or "PXI_TRIG0" or "PXI_TRIG1" or "PXI_TRIG02" or "PXI_TRIG3" or "PXI_TRIG4" or "PXI_TRIG5" or "PXI_TRIG6" or "PXI_TRIG7" or "Channel1" or "Channel2").

TRIGGER_OUTPUT_DESTINATION : Specifies whether or not an accepted trigger appears at an output destination of the digitizer. This is a string containing trigger output pulse ("OFF" or "External" or "PXI_TRIG0" or "PXI_TRIG1" or "PXI_TRIG2" or "PXI_TRIG3" or "PXI_TRIG4" or "PXI_TRIG5" or "PXI_TRIG6" or "PXI_TRIG7").
AttributeValue

The value to which to set the property.
instrument handle out
This control returns an Instrument Handle that is used in all subsequent function calls to differentiate between different sessions of this instrument driver.

Notes:
(1) Each time this function is invoked a Unique Session is opened. It is possible to have more than one session open for the same resource.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Keysight M9217.lvlib:Configure Edge Trigger Source.vi

This VI sets the edge triggering properties. An edge trigger occurs when the trigger signal that the end-user specifies with the Source parameter passes through the voltage threshold that the end-user specifies with the level parameter and has the slope that the end-user specifies with the Slope parameter. This VI affects instrument behavior only if the Trigger Type is Edge Trigger. Set the Trigger Type and Trigger Coupling before calling this VI. If the trigger source is one of the analog input channels, an application program should configure the vertical range, vertical coupling, probe attenuation, and the maximum input frequency before calling this VI.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

Trigger Source (Channel1)

Specifies the trigger source. This value sets the Trigger Source property.

Trigger Level (0 Volt)

Specifies the trigger level. This value sets the Trigger Level property.
Trigger Slope (Trigger Slope Negative)

Specifies the trigger slope. This value sets the Trigger Slope property.

TriggerSlopeNegative : A negative (falling) edge passing through the trigger level triggers the digitizer.

TriggerSlopePositive : A positive (rising) edge passing through the trigger level triggers the digitizer.
instrument handle out
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Keysight M9217.lvlib:Configure Pretrigger Samples.vi

Specifies the number of samples that must be collected before a trigger event will be recognized.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Pretrigger Samples (0)
The number of samples that must be collected before a trigger event will be recognized. The driver sets the Pretrigger Samples property to this value. See the property description for more information and defined values.
instrument handle out
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Keysight M9217.lvlib:Configure Reference Level.vi

Configures the reference levels for waveform measurements, low, mid, and high.

instrument handle

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Low (10)
Measurement low reference. This value sets the Meas Low Ref property.
Mid (50)
Measurement mid reference. This value sets the Meas Mid Ref property.
High (90)

Measurement high reference. This value sets the Meas High Ref property.
instrument handle out

The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Keysight M9217.lvlib:Configure Trigger Holdoff.vi

Specifies the length of time the digitizer waits after it detects a trigger until the digitizer enables the trigger subsystem to detect another trigger. The units are seconds.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Trigger Holdoff (0 sec)
The number of seconds the digitizer waits after it detects a trigger until the digitizer enables the trigger subsystem to detect another trigger. The driver sets the Trigger Modifier property to this value. See the property description for more information and defined values.
instrument handle out
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Keysight M9217.lvlib:Configure Window Trigger Source.vi

Configures the window trigger Source, ThresholdLow, ThresholdHigh, and Condition. A window trigger occurs when a signal that enters or leaves a given voltage range is detected.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Trigger Source (Channel1)
Specifies the trigger source. This value sets the Trigger Source property.
Threshold Low (0 Volts)
Sets the window triggering low threshold in Volts. This value sets the Window Low Threshold property.
Threshold High (0 Volts)
Sets the window triggering high threshold in Volts. This value sets the Window High Threshold property.
Windows Condition (Window Condition Entering)

Specifies whether a pulse that is within or outside the user-specified thresholds trigger waveform acquisition. This value sets the Width Condition property.

WindowConditionEntering: Configures the digitizer to trigger on pulses that have a width that is less than the high threshold and greater than the low threshold. The end-user specifies the high and low thresholds with the Width High Threshold and Width Low Threshold properties.

WindowConditionLeaving: Configures the digitizer to trigger on pulses that have a width that is either greater than the high threshold or less than a low threshold. The end-user specifies the high and low thresholds with the Width High Threshold and Width Low Threshold properties.
instrument handle out
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Keysight M9217.lvlib:Configure Acquisition.vi

This VI configures the most commonly configured properties of the digitizer acquisition sub-system. These properties are the samples per record, the number of records, and the sample rate.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

NumRecordsToAcquire (1)

Specifies the number of records in the acquisition. This value sets the Num Records to Acquire property.
RecordSize (100)

Specifies the number of samples in each record. This value sets the Record Size property.
SampleRate (20000000 S/sec)

Specifies the sample rate in samples per second. This value sets the Sample Rate property.
instrument handle out
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Keysight M9217.lvlib:Configure Channel.vi

This VI configures the most commonly configured properties of the digitizer channel sub-system. These properties are the range, offset, coupling, probe attenuation, and whether the channel is enabled.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

Channel Name (Channel1)

The physical or virtual repeated capability identifier. Pass VI_NULL (0) or empty string if operation does not apply to a repeated capability.

Vertical Range (512 Volts)

Specifies the vertical range. This value sets the Vertical Range property.

Vertical Offset

Specifies the vertical offset. This value sets the Vertical Offset property.
Vertical Coupling (Vertical CouplingAC)

Specifies how to couple the input signal. This value sets the Coupling attribute.

VerticalCouplingAC : The digitizer AC couples the input signal.

VerticalCouplingDC : The digitizer DC couples the input signal.

Channel Enabled (Off)

This parameter is ignored. The channel is always enabled for acquisition.
instrument handle out
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status
The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Keysight M9217.lvlib:Fetch Waveform Int16.vi

This VI returns the waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
Channel Name (Channel1)
The physical or virtual repeated capability identifier. Pass VI_NULL (0) or empty string if operation does not apply to a repeated capability.
Waveform Array Size (100)
Number of elements in WaveformArray.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
instrument handle out
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
Actual Points

Indicates how many data points were actually retrieved from the instrument.
First Valid Point
Indicates the index of the first valid data point in the output data array.
Initial X Offset (sec)
The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.
Initial X Time Seconds (sec)
Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.
Initial X Time Fraction (sec)
Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.
X Increment (sec)
The time between points in the acquired waveform in seconds.
Waveform Array
Buffer into which the acquired waveform is stored.
Numeric
Scale Factor

Scaling factor for the waveform data.
Scale Offset
Scaling offset for the waveform data.


Keysight M9217.lvlib:Fetch Waveform Int32.vi

Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
Channel Name (Channel1)
The physical or virtual repeated capability identifier. Pass VI_NULL (0) or empty string if operation does not apply to a repeated capability.
Waveform Array Size (100)
Number of elements in WaveformArray.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
instrument handle out
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
Actual Points

Indicates how many data points were actually retrieved from the instrument.
First Valid Point
Indicates the index of the first valid data point in the output data array.
Initial X Offset (sec)
The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.
Initial X Time Seconds (sec)
Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.
Initial X Time Fraction (sec)
Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.
X Increment (sec)
The time between points in the acquired waveform in seconds.
Waveform Array
Buffer into which the acquired waveform is stored.
Numeric
Scale Factor

Scaling factor for the waveform data.
Scale Offset
Scaling offset for the waveform data.


Keysight M9217.lvlib:Fetch Waveform Real64.vi

Returns a previously acquired waveform for this channel. The acquisition must be made prior to calling this method. Call this method separately for each channel.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
Channel Name (Channel1)
The physical or virtual repeated capability identifier. Pass VI_NULL (0) or empty string if operation does not apply to a repeated capability.
Waveform Array Size (100)
Number of elements in WaveformArray.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
instrument handle out
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
Actual Points

Indicates how many data points were actually retrieved from the instrument.
First Valid Point
Indicates the index of the first valid data point in the output data array.
Initial X Offset (sec)
The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.
Initial X Time Seconds (sec)
Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.
Initial X Time Fraction (sec)
Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.
X Increment (sec)
The time between points in the acquired waveform in seconds.
Waveform Array
Buffer into which the acquired waveform is stored.
Numeric


Keysight M9217.lvlib:Fetch Multi-Record Waveform Int16.vi

This VI returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
ChannelName (Channel1)

The physical or virtual repeated capability identifier. Pass VI_NULL (0) or empty string if operation does not apply to a repeated capability.
FirstRecord (0)

Specifies the number of the first record to read.
NumRecords (1)
Specifies the number of consecutive records to read.
OffsetWithinRecord (0)
Specifies the start index within the record from which the data should be retrieved.
NumPointsPerRecord (100)
Specifies the number of data points per record to return. This number may be larger than the amount of data available.
WaveformArrayBufferSize (100)
Number of elements in WaveformArray.
instrument handle out
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
WaveformArray
Buffer into which the acquired waveform is stored.
Numeric
WaveformArrayActualSize

Actual number of elements in WaveformArray.
ActualRecords
Indicates how many records in the acquisition completed successfully.
ActualPoints
Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.
Numeric
FirstValidPoint
Indicates the index of the first valid data point in the output data array for each completed record.
Numeric
InitialXOffset (sec)
The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.
Numeric
InitialXTimeSeconds (sec)
Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.
Numeric
InitialXTimeFraction (sec)
Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.
Numeric
XIncrement (sec)

The time between points in the acquired waveform in seconds.
ScaleFactor
Scaling factor for the waveform data.
ScaleOffset
Scaling offset for the waveform data.


Keysight M9217.lvlib:Fetch Multi-Record Waveform Int32.vi

This VI returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
ChannelName (Channel1)

The physical or virtual repeated capability identifier. Pass VI_NULL (0) or empty string if operation does not apply to a repeated capability.
FirstRecord (0)

Specifies the number of the first record to read.
NumRecords (1)

Specifies the number of consecutive records to read.
OffsetWithinRecord (0)

Specifies the start index within the record from which the data should be retrieved.
NumPointsPerRecord (100)

Specifies the number of data points per record to return. This number may be larger than the amount of data available.
WaveformArrayBufferSize (100)

Number of elements in WaveformArray.
instrument handle out
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
WaveformArray
Buffer into which the acquired waveform is stored.
Numeric
WaveformArrayActualSize

Actual number of elements in WaveformArray.
ActualRecords
Indicates how many records in the acquisition completed successfully.
ActualPoints
Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.
Numeric
FirstValidPoint
Indicates the index of the first valid data point in the output data array for each completed record.
Numeric
InitialXOffset (sec)
The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.
Numeric
InitialXTimeSeconds (sec)
Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.
Numeric
InitialXTimeFraction (sec)
Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.
Numeric
XIncrement (sec)

The time between points in the acquired waveform in seconds.
ScaleFactor
Scaling factor for the waveform data.
ScaleOffset
Scaling offset for the waveform data.


Keysight M9217.lvlib:Fetch Multi-Record Waveform Real64.vi

This VI returns the (multi-record) waveform the digitizer acquired for the specified channel. The waveform is from a previously initiated acquisition.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
ChannelName (Channel1)
The physical or virtual repeated capability identifier. Pass VI_NULL (0) or empty string if operation does not apply to a repeated capability.
FirstRecord (0)
Specifies the number of the first record to read.
NumRecords (1)
Specifies the number of consecutive records to read.
OffsetWithinRecord (0)
Specifies the start index within the record from which the data should be retrieved.
NumPointsPerRecord (100)
Specifies the number of data points per record to return. This number may be larger than the amount of data available.
WaveformArrayBufferSize (100)
Number of elements in WaveformArray.
instrument handle out
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
WaveformArray
Buffer into which the acquired waveform is stored.
Numeric
WaveformArrayActualSize

Actual number of elements in WaveformArray.
ActualRecords
Indicates how many records in the acquisition completed successfully.
ActualPoints
Indicates how many data points were actually retrieved from the instrument for each completed record. This is an array of size at least NumRecords or a NULL pointer.
Numeric
FirstValidPoint
Indicates the index of the first valid data point in the output data array for each completed record.
Numeric
InitialXOffset (sec)
The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.
Numeric
InitialXTimeSeconds (sec)
Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.
Numeric
InitialXTimeFraction (sec)
Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.
Numeric
XIncrement (sec)

The time between points in the acquired waveform in seconds.


Keysight M9217.lvlib:Read Waveform Int16.vi

Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
Channel Name (Channel1)
The physical or virtual repeated capability identifier. Pass VI_NULL (0) or empty string if operation does not apply to a repeated capability.
Maximum Time (0 ms)
Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviDigitizerTimeOutEnum are also allowed.
Waveform Array Size (100)
Number of elements in WaveformArray.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
instrument handle out
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
Actual Points
Indicates how many data points were actually retrieved from the instrument.
First Valid Point
Indicates the index of the first valid data point in the output data array.
Initial X Offset (sec)
The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.
Initial X Time Seconds (sec)
Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.
Initial X Time Fraction (sec)
Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.
X Increment (sec)

The time between points in the acquired waveform in seconds.
Waveform Array
Buffer into which the acquired waveform is stored.
Numeric
Scale Factor
Scaling factor for the waveform data.
Scale Offset
Scaling offset for the waveform data.


Keysight M9217.lvlib:Read Waveform Int32.vi

Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
Channel Name (Channel1)
The physical or virtual repeated capability identifier. Pass VI_NULL (0) or empty string if operation does not apply to a repeated capability.
Maximum Time (0 ms)
Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviDigitizerTimeOutEnum are also allowed.
Waveform Array Size (100)
Number of elements in WaveformArray.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
instrument handle out
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
Actual Points
Indicates how many data points were actually retrieved from the instrument.
First Valid Point
Indicates the index of the first valid data point in the output data array.
Initial X Offset (sec)
The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.
Initial X Time Seconds (sec)
Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.
Initial X Time Fraction (sec)
Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.
X Increment (sec)

The time between points in the acquired waveform in seconds.
Waveform Array
Buffer into which the acquired waveform is stored.
Numeric
Scale Factor
Scaling factor for the waveform data.
Scale Offset
Scaling offset for the waveform data.


Keysight M9217.lvlib:Read Waveform Real64.vi

Initiates an acquisition on all enabled channels, waits (up to MaxTimeMilliseconds) for the acquisition to complete, and returns the waveform for this channel. Call FetchWaveform to obtain the waveforms for other channels.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
Channel Name (Channel1)
The physical or virtual repeated capability identifier. Pass VI_NULL (0) or empty string if operation does not apply to a repeated capability.
Maximum Time (0 ms)
Specifies the maximum time the end-user allows for this method to complete in milliseconds. The values defined in IviDigitizerTimeOutEnum are also allowed.
Waveform Array Size (100)
Number of elements in WaveformArray.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
instrument handle out
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
Actual Points
Indicates how many data points were actually retrieved from the instrument.
First Valid Point
Indicates the index of the first valid data point in the output data array.
Initial X Offset (sec)
The time in relation to the Trigger Event of the first point in the waveform in seconds. Negative values mean that the first point in the waveform array was acquired before the trigger event.
Initial X Time Seconds (sec)
Specifies the seconds portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.
Initial X Time Fraction (sec)
Specifies the fractional portion of the absolute time at which the first data point was acquired. Note that the actual time is the sum of InitialXTimeSeconds and InitialXTimeFraction.
X Increment (sec)

The time between points in the acquired waveform in seconds.
Waveform Array
Buffer into which the acquired waveform is stored.
Numeric


Keysight M9217.lvlib:Error Message.vi

Translates the error return value from an IVI driver VI to a user-readable string. The user should pass a buffer with at least 256 bytes for the ErrorMessage parameter.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error code
Instrument driver status code.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
instrument handle out
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error message
Instrument driver error message.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Keysight M9217.lvlib:Reset.vi

Places the instrument in a known state and configures instrument options on which the IVI specific driver depends (for example, enabling/disabling headers). For an IEEE 488.2 instrument, Reset sends the command string *RST to the instrument.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
instrument handle out
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.


Keysight M9217.lvlib:Revision Query.vi

Retrieves revision information from the instrument.

instrument handle
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
instrument handle out
The Instrument Handle that you obtain from the IviDriver_init or IviDriver_InitWithOptions function. The handle identifies a particular instrument session.
instrument driver revision
Returns the revision of the IVI specific driver, which is the value held in the Specific Driver Revision property. Refer to the Specific Driver Revision property for more information.
firmware revision
Returns the firmware revision of the instrument, which is the value held in the Instrument Firmware Revision property. Refer to the Instrument Firmware Revision property for more information.
error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
status

The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
code

The code input identifies the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.
source

The source string describes the origin of the error or warning.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.